John C61743

Member since: Tuesday, 10 April 2018
Last login: 2 weeks ago
Profile viewed: 67 views

No Rank
Points: 0

John C61743 replied to the topic 'Installation Fails due to No Delphi License' in the forum. 3 months ago

I had problems too. Run the license manager and make sure the license for the CURRENTLY ACTIVE license is the ONLY license installed. If you have an older inactive license installed it will cause problems.

C:\Program Files (x86)\Embarcadero\Studio\19.0\bin\LicenseManager.exe

Read More...

I'm trying to use the example included with delphi (FMX Drag And Drop Source)

C:\Users\Public\Documents\Embarcadero\Studio\19.0\Samples\Object Pascal\Multi-Device Samples\User Interface\DragAndDrop

and I am just trying to get the windows (Win 10 Pro X64) to work. When I compile and run the app it throws OLE Errors.

Debug Output: internal\onecorecom\inc\combase\comcataloghelpers.hpp(64)\ole32.dll!7495A59F: (caller: 749EF4E8) ReturnHr(1) tid(bb4) 80040154 Class not registered

Process DragAndDrop.exe (7960) Debug Output: com\ole32\oleregistrationenumeration\oleregistrationenumeration.cpp(34)\ole32.dll!749F021B: (caller: 749F06C3) ReturnHr(2) tid(bb4) 80040154 Class not registered

Process DragAndDrop.exe (7960) Debug Output: com\ole32\oleregistrationenumeration\oleregistrationenumeration.cpp(1009)\ole32.dll!749F06DC: (caller: 749EE9D4) ReturnHr(3) tid(bb4) 80040154 Class not registered

Process DragAndDrop.exe (7960) Debug Output: com\ole32\ole232\stdimpl\oregfmt.cpp(290)\ole32.dll!749C8118: (caller: 749C8AA9) ReturnHr(4) tid(bb4) 80040154 Class not registered

The microsoft MSDN docs say it's because OLE wasn't initialized. I've dug into the source and it doesn't do the Init in the thread that is started to do the D&D. It will Drop onto Wordpad (as text or Image) but with ole errors. I need to drag file links, I've tried adding a file path to the .FILES section of the structure, but it's ignored. I've tried creating a D&D client that just dumps the info in the struct, it shows that the file entry is there but explorer won't see it (drag to desktop). ALSO if you don't successfully drop the drag the app hangs.

Does anyone have this working in Multi-device? I did try the app on MAC (OSX 10.13.3) and while it starts the drag, it won't drop on anything.

Thanks for any help. (Code not included because anyone with delphi 10 has it).

Read More...