ryno C2313

Member since: Monday, 10 August 2015
Last login: 7 months ago
Profile viewed: 706 views

Your Rank: 89
Points: 6

ryno C2313 created a new topic ' What version of XCode/PAServ to use with D10.1 Up1' in the forum. 7 months ago

Hi We're having some issues compiling our IOS app with Delphi 10.1 upd1
What version of Xcode should one use to compile to Apple devices running IOS 10 - 10.1
We've installed XCode v 8.18b62?Pa Server V 9.0.2.03 on the mac
Any help would be great!

Read More...

ryno C2313 created a new topic ' IOS 64bit IPA file size' in the forum. 1 year ago

Hi
when deploying my IOS app to my mac the IPA file size is 87.3mb - After I publish the app to the iStore, Apple sends me a warning telling me that after they do some stuff it will be larger than 100mb and will only allow users to download it over wi-fi. It's quite imperative for me that my app stays below 100mb so that users can download it via mobile connection
Now - I've done some things that in my mind that should have decreased the app size but to no real avail

  • Compressed all the images I use in the app (combined size of all the images is less than 3MB - including splash screens and launcher icons)
  • Removed all unnecessary references to units (cleaned up the "using" sections)
  • Removed all design time components that can be instantiated in code
    • I'm not using livebindings
    • I am using Firedac with SQLite (the database is less than 1MB)
The APK file size is 43 mb which is well below the 50mb max google wants it
Any help or advice in getting the Apple IOS IPA file smaller would be great
Thanks

Read More...

Thanks SarinaI'll keep plowing on - Maybe just upgrade to 10 Seattle

Hi SarinaThanks for the reply1. Delphi XE8 with Update 1 2. IPhoneOS8.4 (but I have XCODE 7 w/IOS9 installed on the MAC running PAServer) 3. Delphi

Hi SarinaI now have IphoneOS8.4 and IphoneOS9.0 SDK in my SDK Manager, my question now is what version of XCODE should be installed on my MAC - I downgraded to 6.4 but when I try and debug the APP I get a build error - "Unable to locate DeviceSupport

ryno C2313 posted a comment on RAD Studio 2015 Roadmap 2 years ago

extremely happy to see native map components for Firemonkey coming up! I am very exited about the future of the FMX platform

ryno C2313 started a new discussion Appmethod V1.3 transferable li... 3 years ago

I Purchased an Appmethod V1.3 license, I still have about 4 months left on it - I then downloaded V1.5 but the license for 1.3 does not work, It says it's expired. I'm sure the license must be transferable between minor versions?...