cupboy

Current status: "android developer name" - 3 months ago
Member since: Sunday, 08 May 2016
Last login: 1 month ago
Profile viewed: 246 views

No Rank
Points: 0

cupboy created a new topic ' raised exception class EListError with message 'Item not found'.' in the forum. 1 month ago

Get this message : Project BusLocate.exe raised exception class EListError with message 'Item not found'. for some unknown reason. How do I even debug this? What control uses EList? This error comes up on the Application.CreateForm after Application.Initialize.

Read More...

cupboy thanked Emailx45 in topic TMultiView problem 1 month ago
cupboy created a new topic ' TMultiView problem' in the forum. 1 month ago

The TMultiview on a TFrame will not cover other controls. If I fill up the whole frame with other controls the TMultiView will not appear at all. As it is it is just a small sliver. The Height property cannot be set. What could be wrong?

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

I converted the service over to .net using the free community edition of Visual Studio 2017 and it writes to the registry just fine. And there's an added advantage of not having to use ADO for the database access so that all works fine too.

Read More...

Is there any way to distribute Android apps not using the Play Store? The way I have to distribute the apps now is having customers either mail in their phone, drive over to the location, or sell them a phone with the app pre-installed. Been trying to figure out Xamarin in my spare time. It doesn't seem like a very good choice so far.

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

I'm under the impression that the Professional version of Delphi 10.2 does not support writing data to the registry. I would assume that those of you who successfully do this are using a pricier version of Delphi (as if the $1,500 that they try to get for Professional isn't enough). I don't know what the high end version is called. Enterprise perhaps? I should download a trial version of Enterprise and do some testing in this regard although at this time I don't have a spare computer to put it on. I'm also going to look around for my Delphi 7 install disk. I'm pretty sure writing to the registry worked in the past because I know I did it.

Read More...

cupboy replied to the topic 'ADO Command parameter being ignored' in the forum. 2 months ago

I've noticed that the recordsAffected variable does not get updated either. Is there something other than ADO that I can use? I'm thinking that ADO no longer functions correctly in newer versions of Delphi. It worked back in the Delphi 7 days.

Read More...

cupboy created a new topic ' ADO Command parameter being ignored' in the forum. 2 months ago

I end up with a date of 12/30/1899 instead of the date I specified.

const
  SQL1 : string = 'UPDATE "SYS COMPANY" SET "SYS COM System Date" = :newsdate';
var
  cmd1 : TADOCommand;
  newdate1 : string;
  recordsAffected : integer;
begin
  try
    newdate1 := '2018-10-24';
    cmd1 := TADOCommand.Create(nil);
    with cmd1 do begin
      Connection := conn1;
      CommandType := cmdText;
      CommandText := SQL1;
      Parameters.ParamByName('newsdate').Value := newdate1;
      Execute(recordsAffected); // results in date of 12/30/1899
    end;


Read More...

cupboy created a new topic ' Using ADO in console program or service fails' in the forum. 2 months ago

I have a variable called conn1 with a type of TADOConnection,
If I try to create it by doing conn1 := TADOConnection.Create(nil) it results in the error message CoInitialize has not been called.

Select all images with fire hydrant: Yep the terrorists won, at least on this site.

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

Not able to post the code. It results in:

Why have I been blocked?

This website is using a security service to protect itself from online attacks. The action you just performed triggered the security solution. There are several actions that could trigger this block including submitting a certain word or phrase, a SQL command or malformed data

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

It is running as LOCALSYSTEM. Is that not an admin account? I've tried the service on two computers. Same result on both.

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

Do any of the services you have write to HKEY_LOCAL_MACHINE? I can read data but not write it. Strangely I can create Keys, just no data.

my error: Failed to set data for 'DataSource':Access is denied

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

The problem was that I installed it using the /INSTALL method. After getting uninstalled with /UNINSTALL I reinstalled it the proper way using sc. So everything is fine now and I avoided using .net.

C:\WINDOWS\system32>sc create CheckDateSvc binPath= checkDateSvcA.exe DisplayName= "checkDateSvc" start= demand
[SC] CreateService SUCCESS

Read More...

cupboy created a new topic ' Service Start parameters come up blank' in the forum. 2 months ago

Checked the windows application log which my service writes to and it shows ParamCount as being 5 which is corrrect but if I try to read any with ParamStr(i) they are all blank and if I display the CmdLine variable all I get is the name of the exe (without the full path.

I was going to read a config file to get the params but I could not get it to do that either since it would just say the file was not found.

Oh yea don't try to install a service using the /Install parameter. Use sc instead.

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

I have tried it with different names already. I guess maybe Delphi services just don't work on Windows 10. Looks like I will have to use the dreaded .net instead.

Read More...

cupboy replied to the topic 'Starting service says cannot find the file specified' in the forum. 2 months ago

yes it is but apparently that is not the file it is looking for

Read More...

cupboy created a new topic ' Starting service says cannot find the file specified' in the forum. 2 months ago

What file name is it looking for? Is there any way to tell? The file name I see in the properties on the Services page does exist but that must not be the file it is really looking for.

Read More...

cupboy created a new topic ' Installing service gets Access is denied' in the forum. 2 months ago

Install it like this: C:\WINDOWS\system32>checkDateService.exe /install
worked fine the first time but now all I get is


Application Error
Exception EOSError in module checkDateService2.exe at 0002B831.

System Error. Code: 5.

Access is denied.


OK

I've tried changing the name of the exe and the name of the service but it didn't matter. The operating system is Windows 10 and the Delphi version is the current version.

Read More...