Notice

The forum is in read only mode.

  • Page:
  • 1

TOPIC: C++Builder: Cannot debug 64 bit app

C++Builder: Cannot debug 64 bit app 7 years 3 months ago #1914

Hello,

I'm trying to check out 64 bit C++ compiler (as it is Clang based, I hope it will better conform to the standard). But the problem is that I cannot debug anything: breakpoints just does not work.

I do the following:
-> Create new project
-> Save all files with some names
-> Replace the whole content of the cpp file with classic "hello world" source like this:

#include <iostream>
#include <ostream>

using namespace std;

int main()
{
cout << "Hello, World!" << endl;
return 0;
}

-> Right-click "Target Platforms" and create 64 bit platform. Make it active.
-> Build the debug configuration. In output window I see that Clang based compiler is used.
-> Set break point at "return" statement.
-> Start debugging (e.g. with F9)

Result:
The application runs OK, but breakpoints are shown crossed (as if no debug information is available) and they are not triggered, so application exits immediately.

The documentation says, that debugging should work basically the same as for 32 bit compiler, but for some reason it does not. I'd highly appreciate if someone could tell me what may be the reason.

Notes:
1. Debugging for 32 bit platform works just fine for me.
2. I tried 64 bit debugging on two versions: XE6 and XE8 - the behavior is the same for both versions.

Thanks in advance.

C++Builder: Cannot debug 64 bit app 7 years 2 months ago #2052

Hi Dimitrij,
I assume that yoou've selected debug Build Configuration, and that Project/Options/C++ Options/Debug has Debug Information set to true.

I just created a VCL Form application, selected 64-bit Windows in Build Configuration, and added a line in TForm1::TForm1(TComponent* Owner) : TForm(Owner) to set a breakpoint at, and it worked fine.

May I recommend that you do the same, and then when you've got it working go from there?
BR
MatsW
The following user(s) said Thank You: Dmitrii

C++Builder: Cannot debug 64 bit app 7 years 2 months ago #2065

Hi Mats

Thanks for your response. Though it did not give me much information, but it nudged me to conduct more tests. :)

After some trials I've found out that the problem was caused by my antivirus. When I disabled it (or then set up some exceptions), debugger started to work as expected for all my examples.

The thing, which confused me is that this problem did not take place for apps created by 32 bit compiler...

Anyway thanks for your willing to help, and maybe this topic will be useful for someone else.

C++Builder: Cannot debug 64 bit app 7 years 2 months ago #2073

Well, that's really odd because I have the opposite problem ( community.embarcadero.com/index.php/foru...ith-remote-debugging ) . I have a Win-7 x64 host running RAD Studio XE6, and I can set breakpoints on a Win-64 apps on a remote WIn-7 X64 host (symbols found). But I can't set breakpoints on the same app compiled for Win-32 when I debug it on a remote Win-7 x32 host, which you don't seem to have a problem with. Is that correct?
  • Page:
  • 1
Moderators: April Anne