Notice

The forum is in read only mode.

  • Page:
  • 1
  • 2

TOPIC: XE8 - iOS App Store Submission.

XE8 - iOS App Store Submission. 7 years 2 months ago #1823

Hi,

I am having a number of major problems with the XE8 development environment.

Currently my most pressing issue is that the IDE seems to have a problem parsing the apple distribution provisioning profile (the development one seems okay).

<auto><auto> option is not working.

If I specifically select the Mobile Provision from the drop down list, then No developer certificates are available in the second drop down (even though a distribution certificate has been included).

In the David I video www.youtube.com/watch?v=Sewa74O5PvA at the 10:44 mark, he demonstrates how it *should* work.

I can find no way around this problem.

Consequently I am getting various errors ultimately to the effect that the distribution certificate is missing.

I would appreciate it if anyone knows a work-around.


screenshot.png

XE8 - iOS App Store Submission. 7 years 2 months ago #1825

the key is getting the
CFBundleIdentifier
set correctly under project, options, version info
try replacing that
e.g
com.yourcompany.[appname]
make sure its exactly as your AP ID is named in itunes
and make when you set up the provisioning profile you selected the certificate with the correct company name too
The following user(s) said Thank You: Peter

XE8 - iOS App Store Submission. 7 years 2 months ago #1868

Thanks for your response Brian.

Unfortunately the CFBundleIdentifier is not the problem. It is in fact getting past this point which I can confirm by putting in an incorrect bundle identifier, in which case I get error
[Warning] Unable to match bundle identifier "au.net.xxxxx" with AppID in all provisioning profiles

When I correct the the bundle identifier so that it matches, I get
[Warning] No certificate found in provisioning profile "xxxxAppStoreMay2015"

So it is finding the correct provisioning profile, matching the bundle ID but cannot see the certificate, which is definitely in the provisioning profile.

A similar issue reported here...
codeverge.com/embarcadero.delphi.deploym...store-provis/2031345
shows that one person regenerated with the profile and redownloaded, which fixed his problem.

I tried that, using a paired programmer to verify that I wasn't making any silly errors, and I still get exactly the same problem.
I have tried deleting certificates/profiles etc from keychains so that I am starting from scratch but I still cannot get past this point.

XE8 - iOS App Store Submission. 7 years 2 months ago #1869

I feel your pain
I went through a similar excercise
and went around in circles for hours but eventually got all the ducks lined up correctly and then it worked :)

XE8 - iOS App Store Submission. 7 years 2 months ago #1871

Still tearing my hair out over this. Has been days now.
Have found if I create a new 'ad hoc' profile for a different project I still get exactly the same error.
So it is recognising my development certificate, but not my distribution certificate!

Are there any embarcadero mobile experts out there who can suggest anything?

XE8 - iOS App Store Submission. 7 years 2 months ago #1876

maybe post some screen shots of the different configurations...
  • Page:
  • 1
  • 2
Moderators: April Anne