Notice

The forum is in read only mode.

  • Page:
  • 1
  • 2

TOPIC: Linker Error LME288

Linker Error LME288 6 years 5 months ago #1636

Hi Dale,

Thanks for sharing a workaround. That is strange behavior indeed. Is this true for both 32-bit and 64-bit builds? Can you please submit a bug report at quality.embarcadero.com so that can process this issue through the QA and engineering teams?
Thanks,
~/jt

Linker Error LME288 6 years 5 months ago #1638

The problem seems to be caused by BDSLauncher. Because the .groupproj file type is associated with BDSLauncher by default on installation, opening the file from Explorer invokes BDSLauncher first. I assume that this is somehow breaking the linker, or at least preventing the linker files from being created. (Could it simply be a file access problem?) I've now changed the file association for .groupproj files to BDS.exe and this seems to have cured the problem.

I have only observed this with 32-bit builds. I have not tried building this project in 64-bit as yet.

I have raised this already through QA with reference RSP-10344.

Linker Error LME288 6 years 5 months ago #1640

Thanks for the additional information and bug report. We'll look into it.
~/jt

Linker Error LME288 5 years 8 months ago #4116

What finally solved this for me was the workaround by Hiroyuki Shimada at http://qc.embarcadero.com/wc/qcmain.aspx?d=134775 . He used MS Visual Studio's "editbin" (also obtainable from http://www.masm32.com/download.htm ). More details, same approach: my writeup on StackOverflow: http://stackoverflow.com/questions/28929516/c-builder-xe7-lme288-error/34819111#34819111 -- see my posting (from "circlepi314") -- upvote it if you like it!

Linker Error LME288 4 years 6 months ago #7804

All of these fixes are just band aids that eventually fall off.

I have Rad Studio 10.1 with update 2. I use C++ exclusively.

The Edit Bin worked for me, then Windows does an update, and now I can't link again. Or even reboot and it will stop working. I know this doesn't make sense but that's how it is.

I've set the Data Execution Prevention to exclude "ilink32.exe", didn't work.

I've set the compatibility of bds.exe to WIN 7 (then the program won't even run).

I've set the ILINK32.exe and BDS.exe to RUN AS ADMIN, doesn't work.

All of the things above may work for a day or two, but none fix the problem.

I currently have a version that was edited with EDITBIN and it doesn't work, I get LME288 errors 100% of the time. So today I have been working for 5 hours and haven't been able to link even once.

I also deleted all files in the WIN32\Debug folder, still get LME288

Started RAD STUDIO with no project, loaded project, still have LME288 error.

Not happy!

Linker Error LME288 4 years 4 months ago #8302

Have you tested to reduce the PATH environment variable? It helped me with XE7. The PATH needed to be shorter than 2048 characters.

Linter Error LME288 has many origins. The above solutions does not help when linker uses a lot of memory.
  • Page:
  • 1
  • 2
Moderators: April Anne