Notice

The forum is in read only mode.

  • Page:
  • 1
  • 2

TOPIC: Linker Error LME288

Linker Error LME288 6 years 5 months ago #1623

Since installing C++Builder XE8 I have been plagued with the linker error LME288, which is preceeded by various warnings complaining about linker files, and "unknown heap name". It has now reached the point where I can rarely link my current project. Sometimes a system restart will fix the problem for a while, but it generally returns very quickly and leaves me completely stuck. I have tried disabling incremental link, but this makes no difference.

Does anyone know of a way around this? I didn't have this problem with XE4 or with XE7 (for the short time I was using the latter).

Linker Error LME288 6 years 5 months ago #1627

I've been doing some more investigation into this. It looks like the problem is related to, or caused by, the linker's .ilc, .ild, .ilf and .ils files being missing (or, perhaps more correctly, not being generated in the first place). I found a suggestion that opening the IDE first and then opening the project seems to clear this problem (rather than opening the IDE by selecting the project from the BDSLauncher icon's jump list, or by double clicking on the project file in Windows Explorer). I tried this and, hey presto, I can now link.

I've found that every time I open the project from within the IDE, it will link. In this case the .ilx files are created. Every time I open it from the BDSLauncher jump list or the project file in Explorer, it fails to link. In this case the .ilx files are not created.

I hope this helps anyone else with the same problem, and maybe it will help Embarcadero fix it! (Well, we live in hope.)

Linker Error LME288 6 years 5 months ago #1636

Hi Dale,

Thanks for sharing a workaround. That is strange behavior indeed. Is this true for both 32-bit and 64-bit builds? Can you please submit a bug report at quality.embarcadero.com so that can process this issue through the QA and engineering teams?
Thanks,
~/jt

Linker Error LME288 6 years 5 months ago #1638

The problem seems to be caused by BDSLauncher. Because the .groupproj file type is associated with BDSLauncher by default on installation, opening the file from Explorer invokes BDSLauncher first. I assume that this is somehow breaking the linker, or at least preventing the linker files from being created. (Could it simply be a file access problem?) I've now changed the file association for .groupproj files to BDS.exe and this seems to have cured the problem.

I have only observed this with 32-bit builds. I have not tried building this project in 64-bit as yet.

I have raised this already through QA with reference RSP-10344.

Linker Error LME288 6 years 5 months ago #1640

Thanks for the additional information and bug report. We'll look into it.
~/jt

Linker Error LME288 5 years 8 months ago #4116

What finally solved this for me was the workaround by Hiroyuki Shimada at http://qc.embarcadero.com/wc/qcmain.aspx?d=134775 . He used MS Visual Studio's "editbin" (also obtainable from http://www.masm32.com/download.htm ). More details, same approach: my writeup on StackOverflow: http://stackoverflow.com/questions/28929516/c-builder-xe7-lme288-error/34819111#34819111 -- see my posting (from "circlepi314") -- upvote it if you like it!
  • Page:
  • 1
  • 2
Moderators: April Anne