Notice

The forum is in read only mode.

  • Page:
  • 1
  • 2

TOPIC: Error after installing Delphi XE8 Update 1

Error after installing Delphi XE8 Update 1 7 years 3 months ago #2561

After having installed Update 1 over Delphi XE8 (Enterprise), I always get this error message when starting the XE8 IDE:



Then I always get the same error message when opening a project in the XE8 IDE (although the project has no connection to the BPL mentioned in the error message).

How can I resolve this problem?

Error after installing Delphi XE8 Update 1 7 years 3 months ago #2607

Have you tried to start the IDE with the option "-rfoo" as explained here:

support.embarcadero.com/es/article/42597

?

If it works, you can check the differences between registry keys to check which could be the issue.

Error after installing Delphi XE8 Update 1 7 years 3 months ago #2636

Peter,
I am having the same problem with C++ Builder XE8 Pro. I intend to use DUnitX so I really need a solution. Did you find one?

- Phyllis

Error after installing Delphi XE8 Update 1 7 years 3 months ago #2637

I've already found a solution. The error message is not a problem after all. See support.embarcadero.com/article/44491

Error after installing Delphi XE8 Update 1 7 years 3 months ago #2639

Phyllis,

thanks for your advice, it seems to work and the Delphi XE8 IDE now does not anymore show the error message at startup.

However, there is another issue: When starting the XE7 IDE (please note: the XE*SEVEN* IDE) I get a huge number of error messages, although I did not install anything in the XE*SEVEN* IDE!

Here are the error messages screenshots:

i.imgur.com/uN6EIeU.gif

How can the installation of the Delphi XE8 Update 1 afflict the XE*SEVEN* IDE? This is really weird!

Should I also click on "No" on these error messages?

Error after installing Delphi XE8 Update 1 7 years 3 months ago #2649

I hadn't been using XE7 since upgrading to XE8, but I still had it installed. I opened XE7 and got 3 or 4 messages related to missing CodeSiteExpressPkg_Design210.bpl. Indeed it is not on my hard drive, but I may have uninstalled this myself - I'm not sure.

Your messages are all related to FastReports which I don't use. If you don't use FastReports in your projects, you can probably answer No and continue working. If you do use FastReports, I think you'll need to recover these libraries. I would backup my project before opening it and answering No. I think this modifies the project, so be careful.

I guess your main concern is whether installing XE8 Update 1 deleted some third-party libraries used by XE7. I can't prove that in my case. If you prove it in your case, I would contact support. These products are supposed to work when installed side by side.
  • Page:
  • 1
  • 2
Moderators: April Anne