Notice

The forum is in read only mode.

  • Page:
  • 1
  • 2

TOPIC: IOS 8.2 App

IOS 8.2 App 7 years 2 months ago #1578

Hello John,

Have you tried the sample in Samples\Object Pascal\Mobile Samples\User Interface\NativeControls ?

If this works for you then you might be able to work out the cause of the problem.

If not, could I suggest that you log the issue via the quality.embarcadero.com website providing clear details on how to reproduce with a test case which will then allow this to be investigated fully.

IOS 8.2 App 7 years 2 months ago #1585

Hi John,

Could you give me some more information about your application?
Is the Controltype property set to Styled or Platform for TListView? Also, is your TListview component connected to a data source?

Quick suggestion:
- Go to File->New->Multi-Device Application->Master Detail Application
- The listview used in this demo is bound to some sample data
- Deploy to your iOS device and let me know if you're able to deploy the app
- Select TListView, and switch the ControlType setting from Styled to Platform and let me know if you're able to deploy the app
- For this test scenario, switch the settings on the Master instead of making them on an iOS specific view

I am not aware of any issue like this so any info you can provide would be helpful in determining a solution.

Regards,
Sarina

IOS 8.2 App 7 years 2 months ago #1634

Hello Sarina,

Thanks for the reply. I tried your suggestion, and I'm still left with the same problem, as soon as I click onto the app i see the firemonkey logo and then the app shuts down.

If it helps, on Xcode I can see this "pid:1004; hostpid: -1>4096, priority: No such process." when i try to open the app.

I'm using Xcode 6.3 with 8.3 SDK, testing on an iPhone 5c running 8.3, developed previously on XE7 and trying to migrate to XE8. But as of the suggestion, it was all in XE8.

In addition to this, I've "dumped" all the controls from my MainForm onto a new Multi-Device project, and deployed over and it works fine without changing anything to do with the TListView's, suggests a project file issue?

Regards,
John.

IOS 8.2 App 7 years 2 months ago #1635

Hi John,

You should check that your entitlement file doesn't contain any carriage return line feeds.
On your Mac, cd to PAServer scratchdir, and then cd to -. In this directory, you will find .entitlements. Open this file in an editor and check that it doesn't contain any carriage return line feeds.

Regards,

Sarina

IOS 8.2 App 7 years 2 months ago #1655

Yes it does, how do I get rid of them and replace them with line feeds?

IOS 8.2 App 7 years 2 months ago #1660

  • Page:
  • 1
  • 2
Moderators: April Anne