SQLITE OSX Firedac Berlin Upate 2


Hi Guys, I have a problem when I try to connect with local SQLITE in OSX. My code works fine on Win32, Android, but when I tried to connect with SQLITE on OSX, I received the message Access Violation at address 000000. I'm using FDConnection. Any ideas?


tks a lot,



  • Accepted Answer

    Tuesday, August 08 2017, 08:32 AM - #Permalink

    Hi Leo,

    Have you had a look at the demo we include with the product?





    The reply is currently minimized Show
  • Responses (1)
    • Accepted Answer

      Thursday, August 10 2017, 07:46 AM - #Permalink

      HI Sarina,


      I tried with demo project and....works. I  put my datamodule in demo project and works too. Looking my project with MacOS (Directive OSX), I found a problem when the connection compoent was created, different when component is creating with directives Android, iOS and Win32;64 . Thanks a lot for answer me, solved my trouble.



      The reply is currently minimized Show
    Your Reply

    Please login to post a reply.........