Enterprise License Center (ELC) und neue Lizenzen (Update Subscription)

Posted by on in Tools

Es kommen hier fast täglich Fragen zum Enterprise License Center (ELC) und aktualisierten Lizenzen. Daher mal eine kleine Anleitung bzw Hilfestellung, was häufiger für Konfusion sorgt: Man hat sich eine 10.1 Berlin Edition gekauft, die automatisch mit einer Update-Subscription daherkommt. Jetzt muss man (wie bei jedem neuen Release), die Lizenzen aktualisieren, um die letzte, aktuelle Version benutzen zu können.

Ich zeige das hier an einem praktischen Beispiel.

Voraussetzungen

  • Dies betrifft nur Lizenzen, die man aufgrund einer aktiven Subscription verlängern kann oder muss
  • Dies trifft nur auf Netzwerk-Lizenzen zu
  • Dies trifft nur auf den ELC (Embarcadero License Center) Version 4.x oder 5.x zu

Beispiel:

  • Man hat sich n Lizenzen von 10.1 Berlin gekauft
  • Man möchte jetzt 10.2 Tokyo installieren
  • Man versucht die SLIP Datei von 10.1 Berlin zu importieren..... und schlägt fehl

Das Problem, was viele Benutzer irritiert: Man versucht auf dem ELC (die Version 5.x kann das automatisch) die Lizenzen zu aktualisieren und sieht weiterhin folgenden Screenshot (Licenses bzw Licenses -> License Files):

Auch wenn man unter Licenses -> License Files auf das "Update licenses" klickt, ändert sich nicht an der Anzeige!

License update status:

-There are no updates found for the license. (<Lizenznummer>)

Lösung:

Unter der Haube wurden die neuen SLIP Dateien angefordert (dies setzt natürlich voraus, daß der Lizenzserver auch Internet-Zugang hat).

Man sieht das auch im Datei-Verzeichnis an dem aktuellen Datum (hier: 20. April 2017):

In diesen Lizenzen steckt auch (bei aktiver Subscription) das letzte/aktuelle Release (10.2 Tokyo). Es wird aber weiterhin "10.1 Berlin" angezeigt. Das mag verwirren. Ist aber leider normal. Es gibt keinen Weg für den Endkunden/Lizenzverwalter herauszufinden, was nun wirklich in den SLIP Dateien steckt....

Die Lizenzen kann man herunterladen (Licenses -> License files -> Download Button (kleiner, blauer Pfeil nach unten).. Das sollte man tun und die darin enthaltene SLIP Datei (NAMED bzw CONCURRENT_xxx.SLIP für die Clientinstallation von Delphi/C++Builder/RAD Studio nutzen)

Ich hoffe, damit für etwas Aufklärung gesorgt zu haben :-)

(Wenn man mir das ZIP Archiv an meine eMail Adresse schickt: Ich kann für Sie / ich kann für euch da reinschauen)

 

ELC 4.x

Für den ELC 4.x muss man sich die Dateien mit den passenden Zugangsdaten (acct-1234567890 / <geheimes Passwort> [1234567890 ist nur ein Beispiel]) hier herunterladen:

Embarcadero-Lizenz-Hosting https://reg.codegear.com/srs6/el/

Daher empfehle ich generell den Einsatz vom ELC 5.x (Download siehe weiter oben; Migration ist ist möglich: Die SLIP Dateien sind kompatibel. Achten Sie bitte auf den Port 4467 vs 5567!)

 



Comments

Check out more tips and tricks in this development video: