April 2017 RAD Studio 10.2 Hotfix for Toolchain Issues

Posted by on in Blogs

We are pleased to release a hotfix for RAD Studio 10.2. This hotfix addresses:

  • debugger issues for Android, iOS, and Linux;
  • Delphi Win64 compiler issues;
  • a C++ RTL issue addressing a crash on exit;
  • a security issue in the C/C++ RTL. Our thanks to Łukasz Wyporek for notifying us of this issue.

You can find full details about each issue in the readme and download page on CodeCentral.

We also have an Android compatibility patch in the works to address Android issues around text input, control rendering and performance.



About
Gold User, No rank,
C++ Product Manager, looking after C++Builder as well as the IDE.

Comments

  • Atilla Y44555
    Atilla Y44555 Sunday, 27 August 2017

    I have purchased the Tokyo Delphi Professional and code completion doesn't work correctly. I am using Delphi 10.2 Version 25.0.27659.1188 Update 1

  • David Millington
    David Millington Thursday, 14 September 2017

    Hi Atilla! Please contact support at https://www.embarcadero.com/support or file a bug report at https://quality.embarcadero.com/

  • James M40502
    James M40502 Thursday, 10 August 2017

    FYI (further to my original post) : I just installed 10.2.1. Linker issues are the same with Kaspersky Total Security 2017 [17.0.0.61(f) on win 10 x64]. I have also confirmed it's likely an AV issue as I do not have the same problem on a VM using the freeware avast AV package.

    While I know you don't take responsibility for third party products but it would be great if you could work in conjunction with, at a minimum, the AV industry leaders to ensure your customers can produce apps in a properly secured environment. AV packages have always been a pain to set up, having to add exclusions and the like, but in this case it's just not possible. If linkers and the like can be submitted and whitelisted or scanned differently it would make the lives of devs so much simpler. Certainly I don't have quite so much grief using VS so it looks like it's possible.

    Cheers

    James

  • David Millington
    David Millington Thursday, 10 August 2017

    Hi James - we do work with them, but one of the most effective things is for their own customers to complain to them.

    In general I recommend whitelisting the entire build folder for a project, as well as the RAD Studio binaries, and manually checking them when you need to verify (eg before publishing a built binary.)

  • James M40502
    James M40502 Thursday, 10 August 2017

    I do appreciate there's two sides to every coin...which is why I have raised a ticket with them (as follows)

    ID INC000008132530,
    I have a few different versions of RAD Studio (Produced by Embarcadero) the latest RAD Studio 10.2 and 10.2.1 (Tokyo) both have issues with linking applications under the c++ environment. Older versions seem fine. I believe they have new versions of their linking app this time around, to resolve issues with memory management. My guess is your AV engine & or heuristic features no longer recognises the linker app and now interact & interfere with it''s operation which makes it fail 90% on my machine. I''ve tried playing with various exclusions, settings & features to no avail.

    I can confirm the app works perfectly well with other AV engines (have mostly tried free ones so far). I would much prefer to keep using Kaspersky than switch to another vendor. Can you please look in to this.

    A free trial of the development package can be obtained here (link). No dount Embarcadero will be more than happy to resolve this issue as I''ve no doubt it affects many of their customers, if my experiences are anything to go by. If they are not I''d be happy to use one of my support tickets on this

    kind regards

    James

  • David Millington
    David Millington Friday, 11 August 2017

    Thanks. Please feel free to let me know what they reply (you can email me at firstname dot lastname at emb.)

  • Rohit Kamat
    Rohit Kamat Wednesday, 9 August 2017

    Hey David - I just installed 10.2.1 and have some new issues. Apps recompiled with 10.2.1 (and no code changes) are showing lots of memory leaks (I had none with 10.2). What's going on? I would like to install updates with confidence - but such events erode confidence in the platform... :(

  • David Millington
    David Millington Thursday, 10 August 2017

    Hi Rohit - is this with a FireMonkey app? If so, we're looking into it! Please follow the two bug reports, RSP-18744 and RSP-18755.

  • Rohit Kamat
    Rohit Kamat Friday, 11 August 2017

    Thanks David - I am the one that logged RSP-18744 :)

    Thanks to Stefan Glienke there is a temporary workaround (outlined in the comments) while EMBT works out the root cause and fixes the issue.

  • Andrew Bond
    Andrew Bond Friday, 21 July 2017

    David

    When are you going to fix the problem with the shipping Boost libraries? As supplied with Tokyo, they CANNOT be used. See RSP-18123 (which still remains unresolved).

    When major flaws like this go unresolved for a long time, existing customers lose confidence in Embarcadero's ability to provide a fit-for-purpose product. Or should I switch to Micrcosoft's products instead?

  • David Millington
    David Millington Thursday, 10 August 2017

    Hi Andrew - I understand. I can only tell you we're working on it.

    (FWIW, Boost can be used - it's the prebuilt portions that have problems. The header-only portions of Boost are fine.)

  • Andrew Bond
    Andrew Bond Friday, 11 August 2017

    David

    I'm astounded at your answer! "We're working on it" months after a reproducible bug report has been submitted to you. This is basic software engineering - do not build your libraries with the meomory manager from the previous release. Surely you know this?

    "Boost can be used - it's the prebuilt portions that have problems. The header-only portions of Boost are fine."

    That's like saying "You can drive the car in first gear, it's just fourth gear that isn't working"

    My confidence in your product has hit rock bottom now.

  • James M40502
    James M40502 Friday, 21 July 2017

    Whilst this is something I've already said it looks like this might be an opportunity to show some solidarity on something that needs to be addressed.
    There needs to be balance between pushing out new features (in conjunction with a new release) and making absolutely sure current releases reach a stable point.
    New releases are no good if they contain broken essential that never get fixed. Maintenance needs to be given a higher priority than it currently has. In this instance Boost libraries have been a part of the toolschain for donkeys years. A lot of Devs will have code that uses it so it should have been tested and proven 100% working before Tokyo was released....because problems like these will affect many, not just Andrew. After discovery of the issues it should have been sorted....because problems will affect many, not just Andrew.
    (David) I note your reply from last Month. "You may be able to rebuild Boost yourself, though that is a lengthy process". It sounds like this issue is fixable, if you rebuild boost, why has this not been done on the Embarcadero end and pushed out as a hotfix or patch?

  • Steve J
    Steve J Friday, 21 July 2017

    I think Andrew is right.
    Same for me. I just renewed my subscription but if things continue to go this way, it's the last time. I have been waiting fro almost 5 months to eventually have NexusDB 3rd party added to GetIt (it was passed to Embarcadero the day after Tokyo was released).
    I opened 1 support ticket (1 of the 3 included with PAID subscription), still no answer, not even studied obviously. Without saying that for 4 weeks it was not possible to check on it as SalesForce had a portal problem not allowing logging in.
    Delphi compiling for the AppStore still doesn't work with the latest Xcode
    This is not serious, especially for that price range, RADStudio is not a 50$ piece.
    Seems to me, it's just a feeling, but everything started to go awry since Idera took over and reduced the teams.
    I have been on the Delphi/C++ bandwagon since 1991... but I fear to be forced out soon. With regrets.

  • David Millington
    David Millington Thursday, 10 August 2017

    Hi Steve - if you have a support ticket that isn't answered, please feel free to forward the email to me (firstname dot lastname at emb.)

    Re your feelings of things going awry: please feel free to email me with a list of issues. It's good to have feedback and data from customers like you.

  • Khodr B41240
    Khodr B41240 Wednesday, 19 July 2017

    Hi
    Almost all of my android programs are suddenly closing after a while after being compiled with Tokyo. So ultimately I resorted to a very minimal test: start a new Multi-Device application... Create an empty form. Put a button and a text or a label on it. Compile and deploy to android 5.01 or 6.1... The application would run for one hour then suddenly closes without any message. This happened on 3 devices with no apparent reason.

    There seems to be a bug somewhere. Memory consumption stays normal. Cpu usage normally. But applications compiled with tokyo always crash after 1 hour or so, even simple apps on brand new devices

    Has anyone experienced a similar problem?

    Thanks

  • denver J42605
    denver J42605 Tuesday, 18 July 2017

    Fresh install of Tokyo then apply this Hotfix try to compile existing Android app and get "FMX.Forms not found" errors (it seems like heaps of other FMX units are missing as they are red-underlined as well) complies fine with fresh Tokyo or Seattle installs.
    I have turned off the Windows Defender anti-virus - the only AV on the machine.

  • Andrew Bond
    Andrew Bond Monday, 19 June 2017

    David

    When will the toolchain be fixe to allow Boost to be used with Tokyo? This is a MAJOR bug, making it impossible for us to upgrade to Tokyo since we rely on boost.

    Please see RSP-18123 (which remains unresolved).

    The proble is that the pre-packaged Boost DLLs that ship with Tokyo have been compiler with the memory Manager from Berlin (!!) - hence at run-time Windows comlains that it cannot find the right emory manager and forces your app to shut down. It is not a workaround to ship the old memory manager, since that causes untold confusion where data is held.

    This bug warrants a re-issue of ALL the Boost libraries. It does not require a hotif for Tokyo as such.

  • David Millington
    David Millington Thursday, 29 June 2017

    Hi Andrew - you're right, and my apologies it's taking so long. You may be able to rebuild Boost yourself, though that is a lengthy process. We're looking into it and I've just escalated it.

  • Laszlo K1618
    Laszlo K1618 Sunday, 18 June 2017

    David!
    You wrote a month ago:
    "We also have an Android compatibility patch in the works to address Android issues around text input, control rendering and performance."
    We are unable to use 10.2, because of the control refreshing problems, that are known at least 6 weeks ago.
    Where is the "promised" patch? Does it take more than 6 weeks? If we would work so slow, we had no customers more...
    It's a shame.

  • Please login first in order for you to submit comments

Check out more tips and tricks in this development video: