Announcing the Release of RAD Studio 10.2.3

Posted by on in Tools

I am excited to announce the release of Delphi, C++Builder and RAD Studio 10.2.3.

10.2 Tokyo, Release 3 (also known as 10.2.3) is an update of Delphi 10.2 Tokyo, C++Builder 10.2 Tokyo and RAD Studio 10.2 Tokyo.

 

Key RAD Studio 10.2.3 Features:

  • CMake Command-Line Support: CMake is a popular C++ build tool. RAD Studio 10.2.3 Tokyo provides support for building CMake projects on the command line using RAD Studio compilers. 10.2.3 also specifically supports using Ninja with CMake, allowing for very fast parallel builds.

  • Rename Refactoring for C++Builder: C++ Rename Refactoring in 10.2 Tokyo Release 3 allows you to right-click an identifier in the code view and quickly rename it throughout your project to improve code readability, reduce errors when renaming, and decrease effort to maintain the project.

  • Inclusion of Mobile Support in Delphi and C++Builder Pro: New in 10.2.3 for Delphi and C++Builder Professional edition is the inclusion of mobile support for new purchases and customers on active Update Subscription. Previously sold as a separate add-on pack for Professional edition, the included mobile support allows Delphi and C++ developers to target iOS and Android, in addition to Windows and macOS, all from a single codebase.

  • FireMonkey UI Templates: 10.2.3 includes a number of new FireMonkey UI templates, designed to highlight FMX's multi-device capabilities, showcase best practices, and help new users get started quicker.

  • Expanded RAD Server Support for Sencha Ext JS: In 10.2.3, we’ve further simplified the development of a RAD Server backend for a Sencha Ext JS client, adding the ability to host static HTML, JS, CSS files (and any other files) in the RAD Server development and debugging server.

Also included are additional enhancements throughout various product areas, and over 100 bug fixes for publicly reported issues.

RAD Studio 10.2.3 also includes all the great features and enhancements we introduced in RAD Studio 10.2, 10.2.1 and 10.2.2.

10.2.3 Docwiki: http://docwiki.embarcadero.com/RADStudio/Tokyo/en/10.2_Tokyo_-_Release_3 


 



About
Gold User, Rank: 5, Points: 558
Senior Product Manager, RAD Studio

Comments

  • Billy Gordon
    Billy Gordon Monday, 16 April 2018

    I am having problems with the 32-bit compiler behaving differntly than the 64-bit one. The 32-bit compiler has issues with losing the this pointer. It has created an unstable version. I have tested on the previous versions with no issues. I can test it in 64-bit with success. I am waiting for a hotfix or another version release to fix this. In the mean time I'm testing previous versions to decide which one will work the best until a new fix is released.

  • GRIPARI G11427
    GRIPARI G11427 Tuesday, 20 March 2018

    Bonjour,

    What about C++ for Linux ?
    In how many days the new version will be ready ?

    GG

  • Niels T5066
    Niels T5066 Sunday, 18 March 2018

    And yet again, we have the "operation error - A problem occurred during the process" when installing. Doesn't anyone care about the out-of-the-box experience at Embarcadero? I'd be embarrassed if my products still suffered from this kind of issue some three years after it was first reported.

  • Niels Thomsen
    Niels Thomsen Thursday, 22 March 2018

    So, in my case the work-round was to run from the desktop link after clicking Cancel in the error dialog. The installation then proceeded just fine. Still not forgiven for not fixing such an issue a long time ago though. Shouldn't need a work-round for installation issues.

  • Peter F37153
    Peter F37153 Thursday, 22 March 2018

    I have the same problem. "Operation error - A problem occurred during the process" when installing.
    I had huge problems to install 10.2.2 and had to install 10.2.1 (working fine) and uninstalled it with help from Swedish support, and was finally able to install 10.2.2.
    Now I uninstalled 10.2.2, installed 10.2.3 and again getting "Operation error" when installing "DirectX".
    Installed 10.2.1 again. Using the old information (what to remove) and following the information "remove file after file". Every trace of the old installation had disappered. Tried to install 10.2.3 again and again getting "Operation error" when installing "DirectX".
    I need assistance!! What can I do to install 10.2.3??
    Why can you not make a proper uninstall program, and a proper install program ...

  • Peter F37153
    Peter F37153 Thursday, 22 March 2018

    Kept on trying. Now I reinstalled and installed only 32 bit platform with no additional options.
    WORKING!! Closed and reinstalled with 32 + 64 bit and mac. WORKING!!!
    All additional options (no additional languages installed) and everything was working ...
    Hopefully you make a proper uninstall program, and a proper install program. Would be very nice!

  • Joko Pitoyo
    Joko Pitoyo Friday, 16 March 2018

    Please add support for mobile google map like, customize infowindow, google streetview and many more...

  • Tobin R60936
    Tobin R60936 Friday, 16 March 2018

    Does this version include any improvements to compile speeds when using the Clang compilers? (RSP-16827)

  • Insertsoft
    Insertsoft Wednesday, 14 March 2018

    REGRESSION-Error in DBGrid Scaling. Text is overlapping each other

  • Insertsoft
    Insertsoft Wednesday, 14 March 2018
  • Marjan O.
    Marjan O. Wednesday, 14 March 2018

    Hi,

    I can't find Firemonkey FireMonkey UI Templates in GetIt :-(

    regards

  • Andy W
    Andy W Wednesday, 14 March 2018

    Nope! Me neither!

    Cart before horse alert!

    Andy

  • Vladimir Klaus
    Vladimir Klaus Tuesday, 13 March 2018

    You have wrong link in "publicly reported issues". It should be http://edn.embarcadero.com/article/44774

  • Sarina D
    Sarina D Wednesday, 14 March 2018

    Thank you, I have fixed the link.

  • Please login first in order for you to submit comments
  • Page :
  • 1

Check out more tips and tricks in this development video: