Using FDExplorer

0

When I try to use FDExplorer to "Import BDE Aliases", I get the error: "BDE driver [Standard] is not supported".

I guess I must be missing something, but what?

I really am trying to get my programs off the BDE but I can't seem to get a FireDAC connection set up.

Thanks

 

Responses (4)
  • Accepted Answer

    Wednesday, March 22 2017, 09:16 AM - #Permalink
    0

    When I get to select Drive ID, the only options in the list are:

    ADS, FB, IB, IBLite, MSACC, MySQL, PG, SQLite

    No ODBC option

    For whatever it's worth:

    In BDE Admin, under Configuration | ODBC, I do see "Microsoft Paradox Driver".

     

     

    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 21 2017, 05:43 AM - #Permalink
    0

    Hi Linda,

    Try....

    1) Create a new VCL project

    2) on Form1 add a single TFDConnection

    3) double click on this TFDConnection

    4) Select DriveID to be "ODBC"

    5) Now in the ODBC Driver entry, can you select "MS Driver for Paradox" ?

    6) Assuming you can,  enter the full path to your Paradox database directory in the "Database" box

    7) close down the configuration window

    8) go to the properties of the TFDConnection

    9) click on "Connected" - this will bring up a password dialog (on our test I have no password protection so just click on OK). The connected check box in the properties should now say "true".

    10) Now you can add a TFDQuery to your form

    11) It will have the property: connection already set to your TFDConnection

    12) Double click on the TFDQuery to bring up the query editor

    13) in the SQL tab enter the following

             SELECT * FROM  yourtablename

    14) click on Execute and you will see all the contents of the table.

    I have just done this with a paradox database on a Win 7 PC using C++ Builder and it all works as described.

    Note: you may want to use the connection wizard (button on the TFDConnection configuration form) as this also sets up ODBC Advanced string which has additional options that can apply to FireDAC ODBC Paradox.

    Hope this helps get you started.

    Regards, Roger.

     

    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 20 2017, 09:09 PM - #Permalink
    0

    Hi Roger,

    Paradox

    On my Windows 7 computer (where Delphi Berlin 10.1 is installed), in the Administrative Tools, Data Sources (ODBC) there is no Paradox option.  On my Windows 10 computer (no Delphi), there are Paradox options.

    Thanks for any help.

    Linda

     

    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 17 2017, 02:22 AM - #Permalink
    0

    Hi Linda,

    What database table type are you trying to interface to? (DBase? Paradox? Access?)

    Regards, Roger

    The reply is currently minimized Show
Your Reply

Please login to post a reply