Tokyo 10.2 Rad studio not compiling to IOS for App Store, Error: E0776 xcrun: error: unable to find utility "PackageApplication", not a developer tool or in PATH

0

Guys Since upgrading from Rad Studio 10.1 Berlin to 10.2 Tokyo, the Compiler want compile to IOS anymore for creating IOS to send to the APP Score. Looks like the Script that does the compiling has an issue. (and seems I am not the only one with this issue, see youtube) https://www.youtube.com/watch?v=NT2Ve_yU6uA   [PAClient Error] Error: E0776 Unable to execute '"/usr/bin/xcrun" -sdk iphoneos PackageApplication -v "/Users/xxxxx/PAServer/scratch-dir/me-mls2/xxxxx.app" -o "/Users/xxxxx/PAServer/scratch-dir/me-mls2/xxxxx.ipa" -sign "iPhone Distribution: xxxxx (6TR54HC4ZC)" --embed "/Users/xxxxxl/Library/MobileDevice/Provisioning Profiles/9d7db578-c51f-4023-a495-c014745f3d07.mobileprovision"' (Error 72) [PAClient Error] Error: E0776 xcrun: error: unable to find utility "PackageApplication", not a developer tool or in PATH Please Help!!    

Responses (9)
  • Accepted Answer

    Thursday, April 20 2017, 09:43 AM - #Permalink
    0

    Solved ?

    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 17 2017, 11:01 AM - #Permalink
    0

    Some problem.

    My solution:

    1. Download old xcode version (v8.2.1) from apple's website
    2. Rename newest xcode app (v8.3 or v8.3.1) to _xcode
    3. Install old version that you just downloaded; it will be named xcode

    That's all it takes to get by until Embarcadero has a fix.

    Until that time I'm using the old version and as soon as a fix comes out I will delete (or rename) xcode version 8.2.1 and replace it with the latest version. Prevents having to download the app again ;)

    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 17 2017, 03:58 AM - #Permalink
    0

    I did not upgrade to Tokyo, I continue with the Berlin version, but it's no good to go back to the version, because apple, returning the version gives the following message: "1.0.2 Binary Rejected Apr 13, 2017 - Guideline 2.1 - Performance During review, your app failed to launch on an iPad and iPhone running iOS 10.3.1 on Wi-Fi connected to an".

    What to do? I urgently need to launch an app in the Apple Store!

    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 06 2017, 02:04 PM - #Permalink
    0

    Hi,

    Please see the workaround for building for the iOS App Store with RAD Studio 10.2 that we posted at http://docwiki.embarcadero.com/PlatformStatus/en/Main_Page#iOS_10

     

    Regards,

    Sarina

    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 06 2017, 02:28 AM - #Permalink
    0

    That's a recurring problem that Embarcadero has to fix once and for all. When xCode is released, they should provide a new PAServer within a week max, not weeks. I'm convinced that this behavior is responsible for many people leaving this nice development environment.

    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 06 2017, 02:26 AM - #Permalink
    0

    Will there be a solution instead of downgrade xcode?

    The reply is currently minimized Show
  • Accepted Answer

    Saturday, April 01 2017, 05:11 AM - #Permalink
    0

    Hi Gebhard,

    Yep., Lots of people will soon have this issue, I wasted 3 days over this issue.

    Apple is aware of this, XCODEBUILD is the replacement for XCRUN but the compiler when passing to XCODE via PACClient passes XCRUN with the

     E0776 Unable to execute '"/usr/bin/xcrun" -sdk iphoneos PackageApplication -v that Fails since Xcode 8.3 has now removed support for PackageApplication via XCRUN.

     

    Hope this gets FIXED ASAP!!!!

     

    The reply is currently minimized Show
  • Accepted Answer

    Saturday, April 01 2017, 04:27 AM - #Permalink
    0

    i have the same problem.

    it is also for Berlin since the Xcode Update

    look here: https://quality.embarcadero.com/browse/RSP-17650

    and vote for it.

    The reply is currently minimized Show
  • Accepted Answer

    Saturday, April 01 2017, 03:02 AM - #Permalink
    0

    I have de same problem :-{

    The reply is currently minimized Show
Your Reply

Please login to post a reply