How to define username and password when deploying an app with IBLite embedded database


I am developing an application that is using an embedded iblite database.  Under the IDE the application runs as expected.  I have specified the username and password to the iblite database in the params section of the configuration.  However when I attempt to deploy this application to another machine using paserver it keeps complaining that: 

First chance exception at $75EB08B2. Exception class EIBNativeException with message '[FireDAC][Phys][IBLite]Your user name and password are not defined. Ask your database administrator to set up an InterBase login.'. Process CinemaManager.exe (20844)

I must be missing something.  I have added code to the create module as follows to see if that helped.






I have added the IBtogo feature to the deployment list and I specified the IBlite version of the license file (reg_iblite.txt).  It seemed to add the required files for IBLite to run.

It still insists that the username and password are not defined.  

I can connect this database to the local interbase server using IBconsole using these credentials so I am pretty sure the username and password are correct.

Thanks in advance if anyone can point out what I am missing here.




Responses (1)
  • Accepted Answer

    Tuesday, February 13 2018, 02:40 PM - #Permalink

    I have found a work around for this problem.  For whatever reason, the new username/password that I created in IBConsole only seemed to work when the application was running in the IDE.  As a test I copied the deployment files for IBLite to the Win32\Debug directory and I think this caused the IDE to start seeing the same issue as the deployed version.  It seems that I needed to use the default sysdba/masterkey username/password to get the deployed version to work.

    I would be interested in any comments regarding setting a different username/password in an IBLite database and how this can be done.


    The reply is currently minimized Show
Your Reply

Please login to post a reply.........