Delphi 10.2 Tokyo: Components do not show some images from TimageList on Android

0

I tried to compile and run original sample application on Android tablet - “ListVieImageIndex”. I found out that some rows of TlistView did not show any picture. Then I created simple program with several buttons, which give image from TimageList and behavior was similar – some buttons were without image.

Same applications compiled in Delphi 10.1. Berlin work well.

Next problem with Delphi is caused by version of Android. It is not possible on Android v.7 to debug a program, because after installation on Android and start process "launching", is debugging stopped with error: “run-as: Could not set capabilities: Operation not permitted”.

Responses (4)
  • Accepted Answer

    Friday, June 23 2017, 11:28 AM - #Permalink
    0

    Hi,

    We have released a FireMonkey Android Compatibility Patch for RAD Studio 10.2 Tokyo.To find out more, and to access the download, please visit https://community.embarcadero.com/blogs/entry/firemonkey-android-compatibility-patch-for-rad-studio-10-2-tokyo

     

    Regards,

    Sarina

    The reply is currently minimized Show
  • Accepted Answer

    Thursday, June 15 2017, 02:26 PM - #Permalink
    0

    hi Al Mannarino, i  build in delphi tokyo the sample ListViewImageIndex  and install in MotoG5 Plus with Android 7 Nougat and obtaing the same error of Pavel. please anyone can help us for fix this!

     

    regards

    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, April 25 2017, 01:41 AM - #Permalink
    0

    Hello Al,

          my screenshot of sample project is below:

     

     

    You can see, that every page loses some images.

    I used for next test original sample project "MobileControls". All my steps were only in design time (there is no my code), when I added several buttons and connected them with images from ImaheList1 (see below):

     

    Run time of this sample excludes image from Button2 (see below)

     

    I use tablet Samsung SM-T815, Android version 6.0.1.

    Thank You for your answer,  good by.

     

    The reply is currently minimized Show
  • Accepted Answer

    Friday, April 21 2017, 12:22 PM - #Permalink
    0

    Hello Pavel - Using the current Delphi 10.2 Tokyo, trying the ListViewImageIndex sample: C:\Users\Public\Documents\Embarcadero\Studio\19.0\Samples\Object Pascal\Multi-Device Samples\User Interface\ListView\ListViewImageIndex\

    Can you include a screenshot of your Android showing what you see?

    I deployed the app to my Android Google Nexus 7 Tablet, and all of the rows of the TlistView do show pictures like this:

    PLAIN+CODE:

    TImageListPlain

    PLAIN+LIVEBINDINGS:

    TImageListLiveBind

     

    DYNAMICAPPEARANCE+CODE

    TImageListDynamic

    DYMANICAPPEARANCE+LIVEBINDINGS:

    TImageListDynamicLiveBind

    Can you send me your "simple program with several buttons, which give image from TimageList and behavior was similar – some buttons were without image".   We would like to test your program and determine any issues.

     

    The reply is currently minimized Show
Your Reply

Please login to post a reply