Context help not installed

0

I have an installation of Rad Studio 10.2 installed on my PC that was installed for me, when I press F1 to invoke the context help I get the following error:

'RAD Studio's help is not installed. Please Re-install RAD Studio's documentation.'

Also, when using the drop down help menu there are no options under 'Help -> Delphi Help'.

I've tried to run the installer to add the help files but the only option I have is to uninstall and re-install RAD Studio which I don't want to do.

I've also downloaded the help files and copied them to  C:\Program Files (x86)\Embarcadero\Studio\19.0\Help\Doc which hasn't resolved the issue.

Is there a method to install the help files so that RAD Studio recognises them without having to reinstall the entire product?

Thank you.

Responses (3)
  • Accepted Answer

    Monday, November 13 2017, 08:07 PM - #Permalink
    0

    I encountered this discussion after experiencing the same issue in Tokyo 10.2.1 - the help system apparently simply disappeared.

    After a lot of googling, I found a Berlin reference to registry entry "HKEY_CURRENT_USER\Software\Embarcadero\BDS\19.0\Help\HtmlHelpFiles" (well, 18.0 for Berlin, I believe...) and checked that entry. All seemed fine.

    I was about to ask for help on the ADUG list when I re-checked that key to find that "HtmlHelpFiles" had been altered to "Html1HelpFiles" (or it may have been "HtmlHelp1Files" - I forget which).

    Removing the superfluous "1" restored operation.

    HOW this entry got changed, IDK.

    20171114T1900Z : I have created RSP-19356 to report this on JIRA.

    The reply is currently minimized Show
  • Accepted Answer

    Monday, September 18 2017, 01:39 PM - #Permalink
    0

    I'm having the same problem with Tokyo 10.2.1.

    I have no help files installed.

    I mounted the ISO and there's exactly one EXE on the INSTALL folder: Setup.exe

    I ran it again and it reinstalled a bunch of stuff, but there's still no help files.

    Per the above suggestions, when I launch the IDE and the Tool menu has no "Manage Platforms" option on it.

    I don't know what the "Feature installer" is. When I tried to run radstudio10_2_1_esd.exe it says it has to uninstall everything first.

    When I looked in the ProgramData (install cache) folder, there are no files with 'help' in their name. Just a bunch of what appear to be compiler exe's.

    This is the second time I've done a full install with no help files showing up for the core system, just what 3rd-party components loaded up.

    Any other suggestions?

    The reply is currently minimized Show
  • Accepted Answer

    Saturday, May 13 2017, 03:24 AM - #Permalink
    0

    Have you used the "Feature installer" (blue/green-ish styled installer) or the ISO?

    For the first one: Launch the IDE. Goto "Tool | Manage Platforms" and install the help.

    For the second one (ISO): Modify the installation through "control panel".

    The reply is currently minimized Show
Your Reply

Please login to post a reply