C++ Builder Code Structure Empty!

0

Hi,

I updated my PC to Windows 10 and since then the code structure panel is empty. Anyone else have this problem?

  • Accepted Answer

    Saturday, August 08 2015, 10:57 AM - #Permalink
    0

    Ok - I was right as the problem lies with Visual J# 2.0.

    Once you upgraded to Windows 10, do the following:

    1) Uninstall Microsoft Visual J# 2.0.

    2) However, since Microsoft do not support it anymore, the uninstall is not complete and you will have to finish it manually.

    3) Remove all references to J# in the registry; there are quite a few so be patient.

    4) Re-boot.

    3) Re-instal Microsoft Visual J# and should install without a problem: http://www.microsoft.com/en-us/download/details.aspx?id=15468

    4) You can now run C++ builder and the insight will also work.

    It appears that with Windows 10, J# is install in a separate directly instead of just under .NET 2.0.

     

    The reply is currently minimized Show
  • Responses (5)
    • Accepted Answer

      Thursday, January 11 2018, 03:26 AM - #Permalink
      1

      I also have this problem with C++ Builder 10.2.2., and it is now at least two and a half years since this problem appeared.  I have tried reinstalling J#2.0. 

      The reply is currently minimized Show
    • Accepted Answer

      Thursday, March 24 2016, 01:03 PM - #Permalink
      0

      In the latest Windows 10 update regedit freezes if you use Find command. I it is quite tedious to try to manually find all references to J# with Regedit. There is a long discussion in Window's support page:

       

      http://answers.microsoft.com/en-us/windows/forum/windows_10-performance/after-windows-10-1511-update-regedit-hangs-on-the/185adedc-ca3c-4ffd-b4bc-bfa8a801d411?auth=1

       

       

      The reply is currently minimized Show
    • Accepted Answer

      Friday, August 07 2015, 07:29 PM - #Permalink
      0

      I have the same problem.

      A few years ago I had this problem and resolved it by re-installing J# and that resolved it.

      Now I noticed that Windows 10 did a new J# 2.0 instillation and I uninstall it from the programs to re-install a fresh version. However, although it is not present anymore, the J# instillation keeps coming up with a message that I must uninstall it.

      For now I am going to try and revert back to Windows 8.1 as I see the Windows 10 gives this option - lets see if this can be done.

      The reply is currently minimized Show
    • Accepted Answer

      Friday, August 07 2015, 07:19 AM - #Permalink
      0

      Hi David,

      Also the code completion seems to never work in W10, I tested it in a copy of my W7 VM before I upgraded it and it is fine in there. 

      Maybe they could take a look at this too?

      The reply is currently minimized Show
    • Accepted Answer

      Thursday, August 06 2015, 03:52 PM - #Permalink
      0

      I recently upgraded my Windows 8.1 VM to Windows 10 and see the same issue using RAD Studio XE8 Subscription Update 1.

      I also tested my Windows 7 VM with RAD Studio XE8 and all is okay. 

      Finally I tested my Windows 10 VM that is original insider preview now the final, not updated from a previous Windows release - same issue.

      Will report the issue to our IDE and C++ teams.

      Thanks Jayden.

       

      The reply is currently minimized Show
    Your Reply

    Please login to post a reply