After updating to iOS 10, MacOS Sierra, and new XCode, iOS debugging now fails

0

I've just updated my iPad to iOS 10 (its 32 bit), updated my Mac's OSX to Sierra and updated XCode to 8 then installed the iOS 10 SDKs into Delphi. All according to the guidelines in http://community.embarcadero.com/blogs/entry/build-apps-for-macos-sierra-and-ios-10-with-berlin-update-1 . Now I can no longer run my iOS apps in Debug from my PC, instead what I get is an endless loop as follows when I press the Run w/ Debug button.

1. It compiles

2 it Deploys and is signed

3 Then the run dialog is shown "Launcing"

4. The Run dialog on the Dev machine disappears and the iOS app shows briefly on the iPad, then it disappears and the run dialog in 3 above reappears.

The loop continues between 3 and 4 probably forever. Eventually I press the "Cancel" button in the Run dialog to abort the loop.

I've let it keep trying for as long as 1/2 an hour.

Note 1. I can run the app from the PC by pressing the "Run without debugging". In that case the app runs on the iOS device fine.

Note 2. When I press the "Cancel" button in the run dialog it displays the http://www.embarcadero.com/starthere/berlin/mobdevsetup/ios/en/runiosdevicefailedhelppage.html page. None of the information on that page applies to my situation.

Note 3. My iOS device is 32 bit, I have not tried with a 64 bit iOS device, but it should still work, right?

Note 4. I've tried rebooting and restarting all three devices (Dev PC, Mac and iPos) but the problem persists. 

Any help on this would be most appreciated.

Best Regards A

lec Bergamini        

Accepted Answer

Thursday, September 29 2016, 05:23 PM - #Permalink
0

Hi Alec,

Regarding iOS 10, 32-bit debugging is currently not supported. 64-bit debugging is supported.

 

Regards,

Sarina

The reply is currently minimized Show
Responses (1)
  • Accepted Answer

    Wednesday, January 11 2017, 09:58 AM - #Permalink
    0

    Hi, Sarina.

    MacOS do the same, I can deploy, update SDK, and run app from IDE but not run in using debug.

    It could be also 32 bit debug not supported in MacOS?, ...but there is no support for macos 64!!!.

    Best regards

    Alexander Brazda

    The reply is currently minimized Show
Your Reply

Please login to post a reply