Adding SDK for IOS gets 'Did you install Command line tools".

0

When I try to ADD an SDK for IOS 32 or 64 I get the error message NO SDK files could be found... did you install command line tools.

I have, but it looks like they cannot be found.

 

I have Xcode 7.1.1 installed on my Mac - running 10.10.5 Yosemite

- and see it in the default location of Macintosh HD/Applications/Utilities

  

I separately installed command line tools 7.1.dmg and see that it installed by default to Library/Developer/commandlinetools 

When I type xcode-select -p  it answers  /Library/Developer/CommandLineTools

I cannot see any folder called xcode.app/contents

If I type sudo xcode-select -s /Application/Xcode.app/Content/Developer  I get "error: invalid developer directory (as it is of course in Library/Developer/commandlinetools.

What am I supposed to do please ?   How do we link to an SDK file please ?

John

 

 

Responses (1)
  • Accepted Answer

    Tuesday, September 12 2017, 01:40 AM - #Permalink
    0

    Good news.  I've solved it - by picking the "Xcode 7.1.1" in the Command line tools combo on the Locations tab in Xcode Preferences.

     

    Embarcadero Documentation gave the clue, but didn't quite describe it (as it suggests going to the Downloads page if that combo box is blank)

    The downloads page didn't offer Command line tools (presumably because I had indeed already got it).

    So I went back to the Locations tab, scratched my head and tried seeing if that blank combo box offered any choices.  It did - so I picked one.

     

    When I then went back to the ADD SDK button in Delphi, it was suddenly happy again.

    So folks, when in doubt, read the friendly manual a little harder .....

    Now onto the next problem....

    John 

     

    The reply is currently minimized Show
Your Reply

Please login to post a reply