Added SDK 11.3 and now cannot link

0

Hi

I have added SDK 11.3 into Tokyo 10.2.3 and now I cannot link to the iPhone. I can link to the simulator, but when trying to the phone I get numerous errors such as 

[DCC Error] E2597 ld: missing required architecture arm64 in file y:\Documents\Embarcadero\Studio\SDKs\iPhoneOS11.3.sdk/usr/lib/system/libcache.dylib (2 slices) for architecture arm64

 

How can I resolve this please?

 

thanks!

  • Accepted Answer

    Thursday, April 12 2018, 08:46 AM - #Permalink
    0

    Just upgraded my Delphi from 10.2 to 10.2.3 and have the same issue !

    so still no solution !

    Anyone ? 

    Thanks

     

    The reply is currently minimized Show
  • Responses (3)
    • Accepted Answer

      Tuesday, April 17 2018, 06:07 AM - #Permalink
      0

      Did you then fully delete the 11.3 form the IDE and go to the entire process of re-adding 11.2 ?

      RadStudio copies all required files locally into My Documents... You need to clean this too. It's not enough to just reinstall Xcode 9.2 and SDK 11.2

      The reply is currently minimized Show
    • Accepted Answer

      Monday, April 16 2018, 10:09 PM - #Permalink
      0

      I reverted to 11.2 SDK.... still failing (Delphi 10.1 Berlin iOS 64bit 11.2)

      [DCC Error] E2597 ld: file not found: /usr/lib/system/libcache.dylib for architecture arm64

      The reply is currently minimized Show
    • Accepted Answer

      Friday, April 13 2018, 01:42 AM - #Permalink
      0

      Marco Cantù said that they're aware of the problem and working on a fix.
      You can revert to SDK 11.2 in the meantime.

      The reply is currently minimized Show
    Your Reply

    Please login to post a reply